Skip to content

IDE Using

We will introduce how to use HX IDE in this page.

Download HX IDE

You can visit website:http://www.anychain.org/ to download HX IDE,now just support for Win7 above platform. Select the 64-bit and 32-bit versions of your system to download.

Start IDE

Once you’ve downloaded it, you’ll get a zip file, unpack it into any directory on your computer, and then open the directory with an AnyChain.exe file inside.double-click on the file to launch your HX IDE.

Start IDE

First start IDE need to setup a store path:

Start IDE

Main Window

Start IDE

Menu Bar Description:

1.In File menu, include

  • New File :create new uvlua/java/c#/kotlin contract file.

  • Import File :import local uvlua/java/c#/kotlin contract file.

  • Save/Save All/Close/Close All :save opened file/save all opened files/close opened file/close all opened file.

  • Configure :change language/theme/chaintype/startchain.

Start IDE

2.In Edit menu, include Redo and Undo.

3.In Contract menu, include Register Contract/UpgradeCcontract/CallContract.

4.In Debug menu, include Compile/Debug/Step/Stop/TabBreak/CleanBreak.

5.In Tool menu include:

  • Console :you can excute rpc command here.

  • AccountManager :you can create a new account or import an account.

  • Transfer :you can send a transfer transaction.

6.In Help menu include:

  • Help F1: Jump to the web site of the contract programming document.

  • About: about us.